www.pimpmychart.com

Einblendung von Datenreihen per Drop-Down

Wie lassen sich per Drop-Down-Liste Datenreihen ein- bzw. ausblenden?

Wenn Sie dem Betrachter eines Diagramms die Möglichkeit bieten möchten, bestimmte Datenreihen ein- und auszublenden, ohne die Datenquelle verändern zu müssen, dann können Sie dies mit Hilfe einer Drop-Down-Liste und einer WENN-Funktion realisieren.

1) Drop-Down Liste erstellen
Schreiben Sie zunächst die gewünschten Inhalte der Drop-Down-Liste (hier: „Yes“ und „No“) in einen Zellbereich (hier: A50:A51). Erstellen Sie dann für jede Quelldatenreihe über „Daten“, „Datenüberprüfung“, „Liste“ ein entsprechendes Drop-Down-Feld (hier B3:G3) und weisen Sie den Zellbereich mit dem Drop-Down-Inhalt als Quelle zu.

2) Quelldaten kopieren
Kopieren Sie nun Ihre Datenquelle (hier A4:G9) in einen neuen Bereich (hier: A12:G17) und löschen Sie die Werte.

3) WENN-Funktion einbauen
Ermitteln Sie per WENN-Funktion welcher Wert aus Ihrer Drop-Down-Liste ausgewählt wurde. Geben Sie hierfür folgende Formel in die Zelle B12 ein: =WENN(B$3="Yes";B4;NV()). Diese Funktion bewirkt, dass bei Auswahl „Yes“ der Wert aus B4 in B12 erscheint und bei Auswahl „No“ kein Wert gezeigt wird. Diese Formel kopieren Sie anschließend bis zur Zelle G17.

4) Datenquelle zuweisen
Nun müssen Sie lediglich noch Ihr Diagramm mit den Werten aus dem Zellbereich A12:G17 verknüpfen und schon lässt sich die Anzeige der Datenreihen einzeln ein- bzw. ausschalten.



Wie hilfreich fanden Sie dieses Tutorial?

Perfekt
Sehr hilfreich
Verwertbar
Wenig hilfreich
Unbrauchbar