www.pimpmychart.com

Bedingte Summierung mit "SUMMEWENN"

Tipp 6: SUMMEWENN

Die Funktion SUMMEWENN erweitert die einfache Summenfunktion von Excel um eine Bedingung. Nur Datensätze, die die angegebene Bedingung erfüllen, werden in die Summenberechnung einbezogen. Die für eine SUMMEWENN-Funktion notwendigen Argumente sind: „Bereich“, „Suchkriterium“ und „Summe_Bereich“. Als „Bereich“ wird der Zellbereich des Datenbestands angegeben, der durchsucht werden soll. Das „Suchkriterium“ stellt den Wert dar, der als Bedingung für die Summierung herangezogen wird. Als „Summe_Bereich“ wird der Bereich angegeben, der summiert werden soll.

Lassen Sie mich dies an einem einfachen Beispiel erläutern: Gegeben sei eine Tabelle mit zwei Spalten (A und B) und zehn Zeilen (2 bis 11). Spalte A ist mit Städtenamen gefüllt, in Spalte B stehen den Städten zugeordnete Werte. Jede Stadt ist zweimal aufgeführt. Wenn Sie nun alle Werte mit einer bestimmten Bezeichnung (hier: Stadt) addieren möchten, ohne diese manuell aus einer Liste herauszusuchen, können Sie dies mit Hilfe der SUMMEWENN-Funktion tun.

Als „Bereich“ geben Sie den kompletten Datenbereich (A2:B11) an. Das Suchkriterium ist die Stadt, deren Werte Sie addieren möchten (z.B. „Frankfurt“). Beachten Sie hier unbedingt die Schreibweise in der Tabelle. Wenn das Suchkriterium nicht exakt der Bezeichnung im Datenbestand entspricht, wird die Summierung scheitern. Wenn Sie, wie in unserem Fall, nach Text suchen, müssen Sie diesen in Anführungszeichen angeben. Wenn Sie Zahlen als Suchkriterium verwenden, können Sie diese ohne Anführungszeichen eingeben. Zuletzt müssen wir noch einen Zellbereich als Summenbereich festlegen. Dieser entspricht dem Bereich, in dem die zu addierenden Werte stehen. In unserem Fall also: B2:B11.

Im linken unteren Eck des Assistenten wird Ihnen bereits bevor Sie auf „OK“ klicken das Formelergebnis angezeigt. Es entspricht der Summe aus den Werten für den Suchbegriff „Frankfurt“. Selbstverständlich können Sie diese, wie auch alle anderen Funktionen anstatt mit dem Funktionsassistenten auch direkt in die Bearbeitungszeile von Excel eingeben. Die Syntax für diesen konkreten Fall lautet: =SUMMEWENN(A2:B11;"Frankfurt";B2:B11).