www.pimpmychart.com

Dynamische Zellbezüge

Tipp 2: Dynamische Zellbezüge

Prüfen Sie ob es sich um eine statische oder eine dynamische Datenquelle handelt, d.h. ob die relevanten Datenbereiche bei der nächsten Datenlieferung in exakt den gleichen Zellen zu finden sind. Ist dies nicht der Fall genügt es nicht auf eine bestimmte Zelle im Quellbereich zu verweisen. Vielmehr müssen Sie dann mit Hilfe von geeigneten Funktionen die entsprechenden Werte aus der Datenquelle ermitteln. Als wichtigste Funktionen in diesem Zusammenhang sind hier sicherlich "SVERWEIS" und "WVERWEIS" (engl. "VLOOKUP" bzw. "HLOOKUP") zu nennen.

SVERWEIS
Diese Funktion kann eingesetzt werden um basierend auf einem Kriterium, die erste Spalte eines Datenbereich zu durchsuchen und den Wert einer bestimmten Zelle einer anderen Spalte zurückzugeben. Hierzu nun ein kurzes Beispiel:


Durch die Funktion: =SVERWEIS(E7;A7:C18;2) in Zelle F7 wird der folgende Suchmechanismus ausgelöst: Der Wert in Zelle E7 (hier: 205) wird im Zellbereich A7:C18 gesucht. Wird dieser Wert gefunden, wird der Wert zurückgegeben, der in der gleichen Zeile wie der gesuchte Wert, jedoch in der 2. Spalte des Suchbereichs liegt (hier B11).

Die Funktion "WVERWEIS" funktioniert in gleicher Weise wie SVERWEIS. Jedoch wird hier nicht die erste Spalte eines Bereichs durchsucht und ein Wert rechts vom gefundenen Wert zurückgegeben, sondern es wird die erste Zeile eines Bereichs durchsucht und ein entsprechender Wert unterhalb des Fundes geliefert.

Weitere nützliche Funktionen zur Datenanalyse bzw. Datenaufbereitung sind u.a. WENN (engl.: IF), SUMMEWENN (SUMIF), KKLEINSTE (SMALL), KGRÖSSTE (LARGE), MAX oder MIN. Am besten lernen Sie neue Funktionen kennen indem Sie diese einfach ausprobieren. Kommen Sie hierbei nicht weiter, googeln Sie einfach danach. Sie werden jede Menge Seiten finden, die Hilfestellung zur Anwendung geben.

Eine Liste aller, in MS Excel verfügbaren Funktionen (mit deutscher und englischer Bezeichnung) finden Sie hier: EXCEL-FUNKTIONEN [44 KB]